Some Plaxo Users Can’t Sync the Address Book in Windows 8, 10

By: Radu Tyrsina
2 minute read

Plaxo is one of the best software when it comes to managing your address book and, naturally, there are many Windows 8 users who have downloaded and installing the service. But it has proved to be problematic for some.
plaxo windows 8
This morning, while browsing through the Microsoft Community support forums and after being pinged by one of our readers, I noticed that some Plaxo users have troubles with their software on Windows 8. Therefore, I decided to make the issue “more public”, so that those affected could get help for their problem. If you have had similar problems, let us know by leaving your comment and we’ll try to find out a solution together. Here’s how the complain sounds like:

Read AlsoaskSam in Windows 8.1 Doesn’t Work for Some Users

I have paid for PLAXO but now I can’t sync my address book. I have a new computer with WINDOWS 8 and NORTON. When I try and download the required tools from PLAXO it keeps on wanting to connect to OUTLOOK EXPRESS instead of WINDOWS LIVE MAIL. Can somebody help me please. I am not a computer expert.

So, as we can see, the problem arrives when you have to connect your mail account, and, in this scenario, it weirdly requires Outlook Express and not Windows Live Mail. But, we all know that Outlook Express isn’t supported anymore for quite a long time, so the best thing that you can do is go ahead and perform a clean install of Plaxo. If this doesn’t work, then leave your comment below and let’s figure out a solution together.

For various PC problems, we recommend to use this tool.

This tool will repair common computer errors, protect you from file loss, malware, hardware failure and optimize your PC for maximum performance. Quickly fix PC issues and prevent others from happening with this software:

  1. Download this PC Repair Tool with Microsoft Technologies
  2. Click “Start Scan” to find Windows issues that could be causing PC problems.
  3. Click “Repair All” to fix all issues (requires upgrade).