Latest Edge Dev build still plagued by bugs, to users' dispair

Reading time icon 3 min. read


Readers help support Windows Report. When you make a purchase using links on our site, we may earn an affiliate commission. Tooltip Icon

Read the affiliate disclosure page to find out how can you help Windows Report effortlessly and without spending any money. Read more

new edge installs in wrong language
XINSTALL BY CLICKING THE DOWNLOAD FILE
A message from our partner

To fix Windows PC system issues, you will need a dedicated tool

  • Download Fortect and install it on your PC
  • Start the tool's scanning process to look for corrupt files that are the source of your problem
  • Right-click on Start Repair so the tool could start the fixing algorythm
Download from Fortect.com Fortect has been downloaded by 0 readers this month, rated 4.4 on TrustPilot

Microsoft recently released Edge Dev Channel build 77.0.235.4 as the final build based on Chromium 77.

The build brought some changes already known from the Canary build, but also a lot of fixes.

Edge Dev build 77.0.235.4 fixed some bugs, but brought new ones

Well, it seems like there weren’t enough fixes, because many Chromium Edge users are reporting all sorts of problems after the update.

One of the new problems involves the Task Manager. After the update to Edge, the text on Task Manager isn’t visible when the dark theme is activated in the browser:

Not sure if this a recent regression or not. Texts onn task manager (shift+esc) on dark theme invisible or dont have enough contrast.

A similar issue previously encountered was already fixed with this build, but as reports show, not for all user.

Another problem that affects the new build is that IE mode is broken. This is a pretty annoying one, and here’s how a user describes it:

IE mode seems to be broken in this build (was working previously). I constantly receive the message saying I have to re-install with administrator permissions or I have to restart Edge to use IE mode. My install path *is* Program Files and not my user directory. I’ve re-installed, though, just to be safe, and I am still getting the error.

Other users are complaining about sign-in pop-ups. This is a known issue from the previous build that has been fixed by Microsoft, but some users are still reporting it.

This is a particularly problematic bug, as it prevents you from signing in on some websites.

After the previous update sign-in pop ups on some sites just close immediately on their own making it impossible to sign in. The fixes around sign-in popups in this update did not resolve that issue

Address and Password Sync still not available for many

Finally, the most common problem is that the new feature that allows users to Sync Addresses and Passwords is still not available for a lot of users:

The note about this release on .microsoftedgeinsider.com whats-new says it includes the ability to sync form fill data and passwords, but in Settings>Profiles>Sync the options to Sync Addresses and Passwords are still not available.

But how can I enable password sync? It is included on the “what’s new” page but it is not listed here.

If that’s on Microsoft and their A/B testing or if it’s a real bug, it remains to be seen in the future.

Hope that the new builds on Chromium 78 will be more stable and bug free.

Have you encountered any of these bugs in the Edge Dev Channel build 77.0.235.4?

More about the topics: bugs, windows 10